Dashboard Delayed
Incident Report for Baremetrics
Resolved
We've sorted out the issue, and now all affected accounts have been or are in the process of being caught up. Sorry for the delays folks!
Posted about 2 months ago. Sep 04, 2017 - 09:52 CDT
Identified
Some accounts are experiencing delays in their metrics. We have identified the issue and are working to resolve it asap.
Posted about 2 months ago. Sep 04, 2017 - 08:31 CDT