Dashboard Outage
Incident Report for Baremetrics
Resolved
We're back in action. Sorry about that folks! 🙏 Metrics might be a bit slower to update as we work to catch up.
Posted 4 months ago. Aug 23, 2017 - 15:37 CDT
Investigating
We're having some server issues. We're working on it! 🔨
Posted 4 months ago. Aug 23, 2017 - 14:59 CDT