App Outage
Incident Report for Baremetrics
Resolved
Fixed!
Posted about 1 year ago. Feb 07, 2017 - 12:14 CST
Investigating
Experiencing some DNS issues! Working on a fix.
Posted about 1 year ago. Feb 07, 2017 - 12:04 CST