Data not loading
Incident Report for Baremetrics
Resolved
Fix deployed.
Posted 7 months ago. Jun 27, 2018 - 11:20 CDT
Investigating
We're looking in to an issue with dashboard data not loading.
Posted 7 months ago. Jun 27, 2018 - 11:08 CDT
This incident affected: Dashboard.