Maintenance
Incident Report for Baremetrics
Resolved
All done!
Posted about 1 year ago. Nov 24, 2017 - 08:47 CST
Identified
We are performing some quick maintenance on our DB. Most users will not notice anything, but for people that do, we should be back to normal very soon.
Posted about 1 year ago. Nov 24, 2017 - 05:34 CST