Some accounts' metrics are delayed

Incident Report for Baremetrics

Resolved

This incident has been resolved.
Posted Jun 27, 2025 - 15:08 CDT

Investigating

We are currently investigating the issue.
Posted Jun 27, 2025 - 09:04 CDT
This incident affected: Dashboard, API, Reports and Notifications, Recover, and Cancellation Insights.