We’re making some behind-the-scenes updates. Some account data may be delayed while we pause syncing temporarily. Everything will be back to normal shortly!

Incident Report for Baremetrics

Resolved

This incident has been resolved.
Posted Jun 10, 2025 - 13:34 CDT

Investigating

We are currently investigating this issue.
Posted Jun 10, 2025 - 10:09 CDT
This incident affected: Dashboard.