Some accounts are behind

Incident Report for Baremetrics

Resolved

This incident has been resolved.
Posted May 08, 2025 - 12:12 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 08, 2025 - 11:17 CDT

Investigating

Some accounts are currently behind. We're investigating the issue and monitoring progress as accounts begin to catch up. It may take a bit of time for all accounts to fully update—thanks for your patience!
Posted May 08, 2025 - 09:37 CDT
This incident affected: Dashboard.