Some accounts are behind

Incident Report for Baremetrics

Resolved

This incident has been resolved.
Posted Feb 05, 2025 - 06:54 CST

Monitoring

We're experiencing some delays in account updates due to a backlog in our system processes. Things are recovering, but updates may take a little longer than usual.
Posted Feb 04, 2025 - 16:34 CST
This incident affected: Dashboard.